[LAU] PHASEX-0.11.0 released

Folderol folderol at ukfsn.org
Sun Aug 12 17:42:32 EDT 2007

On Sun, 12 Aug 2007 18:19:31 +0200
Nigel Henry <cave.dnb at tiscali.fr> wrote:

> On Wednesday 08 August 2007 10:20, William Weston wrote:
> > On Tue, 7 Aug 2007, Carlos Pino wrote:
> > > Hi , good news . It compiles ok but doesn't work for me on Debian Etch ,
> > > segfault is the only message that appears on the terminal output .
> >
> > Can you run 'phasex -d' to get the debugging output?  That should
> > give us some indication of how far it gets before the segfault.
> >
> >
> > Thanks for the report,
> > --ww
> I get the same output from phasex -d as Cesare, see below.
> ~$ phasex -d
> JACK is running without realtime scheduling.
> JACK sample rate:  44100
> Internal sample rate:  44100
> JACK requested sample rate:  44100
> JACK output buffer size:  1024.
> Filter Limit:  47131
> Denormal Offset: 0.0000000000000000099999998377515902427
> Segmentation fault
> That's with phasex-0.11.0 on Debian Etch. I have an earlier version of Phasex 
> on Lenny, and that works fine. I hadn't tried the earlier Phasex on Etch, so 
> did a make uninstall of the 0.11.0 version, and built and installed the 
> 0.10.3 version, which works fine on Etch.
> I've sent you a screenshot offlist of all I get before Phasex segfaults. It's 
> too big to send to the list. It's onscreen for about 1/4 second before the 
> segfault.
> Nigel.

I had an interesting varient of this.

I'm using 64studio (on two different 64bit machines)

When i first compiled this it ran fine for a while. It was only when I
started opening different parameter files that it crashed, and from
then on did the same as you found every time I tried to restart it.

Exactly the same thing happened with both machines.

Also, thinking it may be a corrupted .rc file or the like I tried
removing .phasex from my home directory. I also tried logging out and
logging back in, and then tried a reboot. Still it stubbornly refused to

Finally I tried re-compiling and reinstalling it, as well as
removing .phasex AND rebooting.

Guess what... It still segfaults.

I have no idea how this could be possible!

Will J Godfrey

More information about the Linux-audio-user mailing list