[LAU] Problems with horgand-v1.11 (xruns)

Nigel Henry cave.dnb at tiscali.fr
Fri Aug 31 14:38:58 EDT 2007

I havn't seen Horgand before, but built it on Fedora 7, using the default Alsa 
audio out. It launched with no problems, but when playing keys on my usb midi 
keyboard, I was getting something that sounded like xruns. I've left it a 
couple of days, and had a few updates for Fedora 7. I launched Horgand again, 
still heard what appear to be xruns, and decided to change the audio output 
to Jack. Bad move!!!. I can no longer launch Horgand. I tried a bunch of 
stuff. A make uninstall, and removing stuff that was left behind, 
(~/.horgand, and an empty directory in /usr/local/share, followed by a make 
install. Still no launch of the app. next I removed the directory created 
from unpacking the tarball, and recreated the directory. Then did 
a ./configure, make, and make install again. Still nothing. It appears that 
I've killed it by trying to get it to use Jack.

I'm not giving up, so I boot up Debian Etch on the same machine. Build Horgand 
on Etch, setup the desktop launcher, and it's nice that there is an icon for 
Horgand, and a nice one too. I launch it, and it opens just fine, but I'm 
getting these same sort of xrun sounds when playing it. Shut it down, and 
launch it from a terminal. 2 lines are printed, followed by continual lines 
of xruns!, and I havn't touched a key on the keyboard, and the keyboard isn't 
even connected in Qjackctl's midi connections.

I havn't tried changing the audio out to Jack, as I don't want to screw up 
Horgand on Etch, as changing to Jack on Fedora 7 seems to have done. Doh!

Any suggestions to resolve the xrun problem? This seems like a nice app, and 
it would be nice to get it working well.

Best regards.


More information about the Linux-audio-user mailing list