[LAU] beginning audio setup: sblive midi not working

Nigel Henry cave.dnb at tiscali.fr
Sun Jun 3 10:46:58 EDT 2007

On Sunday 03 June 2007 15:20, Hein Zelle wrote:
> Hello list,
> I'm new to audio recording, and have a couple of unsolved questions
> after getting my basic setup working.  I've searched the archives
> using google (is there a list-specific search somewhere?), but haven't
> found a solution.  I'm currently using
> - pc with sblive! soundcard
> - 2.6.20-rt8 kernel, by patching stock debian kernel 2.6.20
> - external evolution usb midi keyboard
> - external 4-channel mixer
> - timidity as a soft-synth
> - ardour 2.0 for audio recording
> - rosegarden for midi recording.
> - jack + qjackctl to connect it all
> All that seems to work reasonably well, and since the realtime kernel
> there are no noticeable latency problems.  I do get the occasional
> xrun (about once every 5 minutes or so) but it hasn't been
> bothersome.
> The thing I cannot get to work is midi playing through the sblive
> soundcard.  I've followed countless howto's, yet all I get is dead
> silence.  The card works for normal audio, all modules including
> snd_emu10k1_synth and snd_emux_synth.  I've tried loading the
> soundfont like so

big snip

> I've tried to connect 20:0 to 16:0, and also to 17:0,1,2,3, to no
> avail.  What should I be connecting?  Any other hints as to why my
> sblive card won't play midi?
> Here's the output of lspci -v:
> 00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev
> 04) Subsystem: Creative Labs CT4850 SBLive! Value
>         Flags: bus master, medium devsel, latency 32, IRQ 17
>         I/O ports at a400 [size=32]
>         Capabilities: [dc] Power Management version 1
> Any help will be much appreciated.
> Kind regards,
>      Hein Zelle

Have a look in alsamixer on the CLI. You do need the control "Music" to be up. 
This control used to be called "Synth" which made more sense. I've just 
checked it on Etch with my 225C, and it plays ok, but a bit quiet. I just 
connected the keyboard (72) to 0 Emu10k1 Port0.


More information about the Linux-audio-user mailing list