[LAU] Delta66 problem... solved!!

Jorge spesgmd at telefonica.net
Sat Apr 12 09:05:57 EDT 2008

This was an answer to Raphael Bollen, but as the mail was returned (exceeded 
storage allocation), I send it here, I hope it's also useful fore someone 
else :)

BTW I'm being testing the card and it works perfect now for analog I/O (with 
this "fix"), the Delta66 is a great card ;)


> Hi Jorge,
> Glad to hear this. How did you do this exactly, I tried to add this option
> to the module: options snd_ice1712 model=vx442
> but it did not work for me :-(
> Did you do something else to have it working?

That's exactly what I did, and it works... Are you sure you removed the 
snd_ice1712 module first from the kernel with rmmod? it shouldn't appear when 
you do lsmod before trying to load the new kernel. Try to load it manually 
first with:

modprobe snd_ice1712 model=vx442

and then if it works, add the line:

options  snd_ice1712  model=vx442

to a file /etc/modprobe.d/delta66_revE_hack_vx442

(the name of that file can be whatever you like, but it has to be in that 

If your problem is exactly the "revisionE" of the Delta66, that works for 
sure... good luck!! :)


More information about the Linux-audio-user mailing list