[LAU] disappointing experience with firewire

Jörn Nettingsmeier nettings at folkwang-hochschule.de
Wed Dec 31 11:09:22 EST 2008

hi susanne!

Susanne Schneider wrote:
> hi,
> this is no complaint (!) about anything, just to reflect over my 
> yesterday's exerience with a newly purchased Focusrite Saffire Pro10, 
> connected via Belkin PCMCIA Firewirecard to my Lenovo R61 - the FW Chip 
> in this Laptop is one of those crappy Ricoh parts, I tried this, too, 
> but as expected it just didn't work...
> So I compiled the ffado Release Candidate, afterwards compiled the 
> actual Jack 0.116.1 and finally got things running.
> Compared to my Lexicon Omega Studio USB Device the performance of that 
> FW assembly (don't want to blame a single device of that chain) just was 
> disappointing, already in idlemode without any clients open the 
> jackserver showed a workload of roughly 5% (128 frames/3 periods), while 
> my Lexicon produces between 0.5 to 1% (128 frames/2 periods).

well, ffado is more cpu-intensive than a kernel driver. there's no way
around that. as to the figured you mention: how many channels does your
lexicon have? in my experience, the cpu load is somewhat proportional to
the number of channels ffado has to heave back and forth. for
comparison, my saffire pro26 (26 channels i/o) uses close to 12% cpu,
and proportionally less if i disable the additional adat i/os.

> Opening Ardour and just replaying one of my sessions produced glitches 
> where only a strong hiss could be heard. (The session itself caused a 
> workload of less than 20%.) - I remember having had those hiss glitches 
> in my early days in 2005 with the MAudio Transit USB and Kernel 2.6.11 - 
> I never expected them coming back some day... *lol*
> I then had a look on my interrupts and had to notice the FW Card sharing 
> it's interrupt (no 16) with the Nwidia Graficscard - so I might have 
> found the culprit - or not? - I don't know... :-(((
> I tried to change the pci settings in the bios - no success.
> Now my question to those who also tried firewire audio: was it a success 
> story for you from the beginning or did anybody make similar experiences 
> and how did you proceed further?

yeah, firewire is tricky. you definitely need real-time privileges, and
an rt kernel doesn't hurt either. i'm currently not using one for
various reasons, but i have frequent xruns with large sessions.... when
i'm tracking live, i always use one.

ieee1394 controllers are another hairy issue. both chips i use (a pc
card and the one built into my studio box) behave well, but i've heard
people have had a hard time with theirs.

if you want to dig in deeper, you should probably move this thread to
the ffado-user list.

regarding your interrupt woes: are you running a closed-source nvidia
driver? if so, throw it out if at all possible.

just as a final reassuring remark: despite some rough edges, my saffire
is performing nicely. sometimes ardour kills jackd when loading my
current session, but this is a 20ch monster with 5 nine-channel busses
:) restarting jackd and reconnecting ardour fixes it for me.



More information about the Linux-audio-user mailing list