[LAU] pops & clicks

verymeta at riseup.net verymeta at riseup.net
Thu Feb 14 11:05:05 EST 2008

Thanks for the quick reply! I'll try to answer these questions...

> I assume you are using freebob and not ffado.


> Some things to check:
> * are you running jackd with the realtime flag?

Yes, 'realtime' is ticked in the qjackctl settings.

> * do you alleviate the priority of the ohci1394 interrupt above other
interrupt sources? (e.g. with the rtirq)

No. I tried messing with IRQ priorities a couple of days back, but I
didn't really know what I was doing and the only thing that happened was
the menu bars on my desktop would disappear randomly when I started jack,
I've reinstalled Ubuntu since then. Do you think it would help if I
installed rtirq?

> * does dmesg show anything special regarding 1394?

$ dmesg|grep 1394
[   12.564436] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[19] 
MMIO=[fe4ff000-fe4ff7ff]  Max Packet=[2048]  IR/IT contexts=[8/8]
[   13.822759] ieee1394: Host added: ID:BUS[0-00:1023] 
[   13.829370] ieee1394: Node added: ID:BUS[0-01:1023] 
[   20.828189] ieee1394: raw1394: /dev/raw1394 device initialized
[   20.835615] NOTE: The dv1394 driver is unsupported and may be removed
in a future Linux release. Use raw1394 instead.

> * what firewire chipset do you use? (lspci | grep 1394)

$ lspci|grep 1394
03:01.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)

> * are you using -n3 (to specify the usage of 3 buffers of one period)?

Normally I just start jackd with qjackctl. Just now I tried starting it in
the terminal with:

$ jackd -R -d freebob -n3

and it didn't make any difference to the sound.

I don't know if any of that is interesting...


More information about the Linux-audio-user mailing list