[LAU] Lash 0.6.0-rc2 compiling help

Joel Roth joelz at pobox.com
Mon Feb 2 21:14:28 EST 2009

On Tue, Feb 03, 2009 at 08:53:44AM +0800, Ray Rashif wrote:
> There's no problem with compilation. If any, it'd be distro-specific
> (dependencies, needed *-devel files if any, version mismatch etc). Run
> configure with a prefix:
> ./configure --prefix=/usr

I see that takes care of most of the headers:


However, I still get the same error as before:

gcc -DHAVE_CONFIG_H -I. -I../..  -I../..  -I/usr/local/include   -I/usr/include/alsa   -g -O2 -MT lash_simple_client-simple_client.o -MD -MP -MF .deps/lash_simple_client-simple_client.Tpo -c -o lash_simple_client-simple_client.o `test -f 'simple_client.c' || echo './'`simple_client.c
simple_client.c: In function 'main':
simple_client.c:94: error: 'JackNullOption' undeclared (first use in this function)

Shouldn't there be an '-I/usr/include' appearing above?

Also what is the standard way to exclude simple_client
from compiling?

> The following are known dependencies:

> dbus
> gtk2
> jack
> libxml2
> python

I have all of these. 



Joel Roth

More information about the Linux-audio-user mailing list