[LAU] trouble with compiled jack/qjackctl/ffado

Jörn Nettingsmeier nettings at folkwang-hochschule.de
Mon Mar 30 06:55:53 EDT 2009

Atte André Jensen wrote:
> If I run jack from commandline like this (stolen from .jackdrc, 
> generated by qjackctl):
> /usr/bin/jackd -v -R -P80 -t1000 -m -dfirewire -r44100 -p512 -n2
> jack starts just fine.
> However I can't no longer start it from qjackctl, I get this in messages:
> 11:54:17.005 /usr/bin/jackd -v -R -P80 -t1000 -m -dfirewire -r44100 
> -p512 -n2
> could not open driver .so '/usr/lib/jack/jack_firewire.so': libffado.so: 
> cannot open shared object file: No such file or directory
> getting driver descriptor from /usr/lib/jack/jack_alsa.so
> jackd: unknown driver 'firewire'
> Why is that? I even tried compiling qjackctl by hand, but the same 
> problem. Seems like it's the same commandline, right? Then why can't 
> jack started by qjackctl find the libffado.so?

a shot in the dark: might this be a linker cache issue?
try "ldconfig" as root. although i doubt it will help...

More information about the Linux-audio-user mailing list