[LAU] SOLVED - Crashing Audacity 1.3.9 on Mandriva 2010.0

Kevin Cosgrove kevinc at cosgroves.us
Wed Mar 31 21:43:43 EDT 2010

The problem is solved.

I reenabled PulseAudio.

I changed my /etc/modprobe.conf from this

    alias sound-slot-0 snd_ice1712
    alias sound-slot-1 snd_ice1712
    alias sound-slot-2 snd_ens1371

to this

    alias sound-slot-0 snd_ens1371
    alias sound-slot-1 snd_ice1712
    alias sound-slot-2 snd_ice1712

Then I rebooted. After the machine was back up, Amarok worked
with PulseAudio enabled. Audacity 1.3.11 shows only ALSA in its
host type list. For playback I chose the ENS1371 card, which is
now my default. For recording, I could only choose "default", so
that's what I chose. Edits in that dialog do not cause crashing
when okayed. Audacity records just fine now. What's more, when
I do a mic check for of Audacity's input, I hear the output on
my speakers. My ENS1371 card has never been that full duplex
before. Maybe I should credit PulseAudio with that behavior?

Anyway, everything works and I believe the main cause of that
was reordering my sound devices in /etc/modprobe.conf which now
agrees with the order I had before I upgraded my distribution
from Mandriva 2007.0 to Mandriva 2010.0.

I hope this info helps the next person to face a similar


More information about the Linux-audio-user mailing list