[LAU] options for hard real time kernel for raring 13.04

Jeremy Jongepier jeremy at autostatic.com
Wed Sep 11 18:00:22 UTC 2013

On 09/11/2013 04:46 PM, Marco Donnarumma wrote:
> update:
> 1_ tried to install 3.10-2-rt-686-pae_3.10.7-1_i386.deb from
> http://packages.debian.org/jessie/linux-image-3.10-2-rt-686-pae, but it
> didn't like my initramfs-tools version (apparently too old for the new
> kernel) and installed without configuration so had to remove. See log:
> dpkg: dependency problems prevent configuration of initramfs-tools:
>  linux-image-3.10-2-rt-686-pae (3.10.7-1) breaks initramfs-tools (<<
> 0.110~) and is unpacked but not configured.
>   Version of initramfs-tools to be configured is 0.103ubuntu0.7.
> 2_ my low-latency kernel is 3.8.0*. I compiled my own rt-kernel, using
> http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.2.48.tar.bz2 and its
> related rt patch, as in the tutorial that Jeremy posted. The kernel
> compiles and installs fine, but when I load it from grub, Mint load
> correctly, and then (before seeing anything on screen) my screen goes
> black. Nothing to do there, tried to use hotkeys to get a tty, restart, or
> shutdown, but had only to push the power button.

Switching tty's probably works but you don't see it. Did you try
switching with Alt+F1 and then rebooting with Ctrl+Alt+Del? If that
doesn't work you could try Alt+SysRq+R,E,I,S,U,B, that should cleanly
reboot the machine.

> It's probably an nvidia driver-related issue, am I correct?
> Found some suggestions about patching the nvidia driver with some custom
> code here [1], but the driver they use there is quite old. And last time I
> had fiddled with nvidia driver it was the most painful experience ever... :)

Did you try the patch in my Github repository? You can download it with:

And then patch the Nvidia source, unfortunately I do noy know by heart
how to proceed.



> Will investigate further, please throw me suggestions if any,
> I might ask falkTX how he sees the rt-kernel for 13.04. I saw there is some
> working on Launchpad, but they are last modified sept. 2012 (?).
> thank you!
> best,
> M
> [1]
> --
> Marco Donnarumma
> New Media + Sonic Arts Practitioner, Performer, Teacher, Director.
> Embodied Audio-Visual Interaction Research Team.
> Department of Computing, Goldsmiths University of London
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Portfolio: http://marcodonnarumma.com
> Research: http://res.marcodonnarumma.com
> Director: http://www.liveperformersmeeting.net
> On Wed, Sep 11, 2013 at 2:02 PM, Marco Donnarumma <devel at thesaddj.com>wrote:
>>  Did you consider building your own kernel? I'm using self-built RT
>>> kernels on Ubuntu 12.04 and that works great:
>>> http://wiki.linuxaudio.org/wiki/system_configuration#build_your_own_real-time_kernel
>>> And are you using rtirq?
>>> Alessio Abogani stopped maintaining th RT kernels for Ubuntu quite a
>>> while ago. You might want to ask falkTX about the possibilities of
>>> offering a raring RT kernel.
>>> Best,
>>> Jeremy
>> Hey Jeremy!
>> Yes, that's the other thing I will try now, good to know it works on 12.04.
>> My pain in the a... is that I have to use nvidia drivers, and had troubles
>> some time ago with them and rt-kernels.
>> Do you happen to know whether I need to patch nvidia support into the
>> rt-kernel I build? (I guess so... just to be sure)
>> thanks!
>> best,
>> M

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20130911/09b67ada/attachment.pgp>

More information about the Linux-audio-user mailing list