[LAU] dssi-vst doesn't see certain .dll files

Aiyumi Moriya aiyumi.br at gmail.com
Fri Oct 10 22:10:54 UTC 2014

> Date: Thu, 9 Oct 2014 10:35:54 +0200
> From: Renato <rennabh at gmail.com>
> To: lau <linux-audio-user at lists.linuxaudio.org>
> Subject: Re: [LAU] dssi-vst doesn't see certain .dll files
> Message-ID: <20141009103554.29b9693b at gmail.com>
> Content-Type: text/plain; charset=US-ASCII
> [...]
> With vsthost you don't usually need the full path, it looks in
> $VST_PATH I think which has /home/renato/Audio/.vst. And anyways other
> windows vsts in that directory launch correctly, so I wouldn't say it's
> a path problem. Neither an architecture problem as far as I can see,
> since as said I tried putting in the directory both 64bit and 32bit
> versions of Kontakt.

I vaguely remember having a problem like yours when I tried to use
Kontakt Player's VST... I think vsthost doesn't like uppercase and
spaces in filenames. Here it was renamed to "kontakt5.dll" and it
works. Dssi_list_plugins says:

        TS                Trivial synth
        LTS               Less Trivial synth
        karplong          Simple Karplus-Strong Plucked String Synth
        LinuxSampler      LinuxSampler
        stereo_sampler    Simple Stereo Sampler
        mono_sampler      Simple Mono Sampler
RemoteVSTClient: all cache files are up-to-date, not running scanner
        kontakt5.dll      Kontakt 5 VST

I still couldn't make the 8 and 16 output DLLs work though. (I don't
need 64 outs! ... Or at least, not yet. :D)


Blog: http://aiyumi.warpstar.net/

More information about the Linux-audio-user mailing list