[LAU] OpenMusic 6.9 - new build for Ubuntu (.deb) and Fedora (.rpm)

Daniel Appelt daniel.appelt at gmail.com
Thu Feb 5 10:54:48 UTC 2015

2015-02-05 10:36 GMT+01:00  <anders.vinjar at bek.no>:
> Yes, i remember the previous round.  Did you pinpoint this to the 32bit
> libgdk_pixbuf on your machine?

Yes. I got the information from Martin that they are using
GdkPixbufLoader in LispWorks, and he provided me with a corresponding
C source, a modification of which I used for filing the GDK bug that I
have mentioned.

> To do a quick check now, grab an updated "lw personal" and run a small
> test-script:
> (let ((test-image "/some/tiff/image.tiff"))
>   (capi:contain (make-instance 'capi:output-pane
>                                :display-callback
>                                #'(lambda (pane &rest x)
>                                    (let ((img (gp:load-image pane test-image)))
>                                      (gp:draw-image pane img 0 0))))))
> and just to be sure, substitute with a few other formats (jpg, png, bmp,
> whatever).

I did this back then with LispWorks PE 6.1.1 but I might try it again
if there is a newer version available. These were the results I gave
to Martin:

>> With the following test code I am not able to load any TIFF images on my
>> system (see log below).
>> *(let ((test-image "/home/daniel/grafik/profil.tiff"))  (capi:contain
>> (make-instance 'capi:output-pane
>>  :display-callback                               #'(lambda (pane &rest x)
>>                                  (declare (ignore x))
>>              (let ((img (gp:load-image pane test-image)))
>>                    (gp:draw-image pane img 0 0))))))*
>> I have tried TIFF images from different sources and created by different
>> programs. All yield the same error.
>> These formats are said to be known here:
>> CL-USER 17 : 1 > (gp:list-known-image-formats nil)
>> I created a test image in nearly each of these formats (except GDKPIXDATA,
>> CUR, ICO) using convert (ImageMagick). The code above worked for all the
>> created images (with the respective file) except for TIFF and RAS.

>     D> and wich version of libgdk_pixbuf 32bit is installed in your
>     D> 64bit environment?
> libgdk_pixbuf-2.0.so.0.3000.3

I have a newer version on my system: libgdk_pixbuf-2.0.so.0.3100.1
I have already created it with debugging symbols but got stock at some
point of debugging, Maybe I will try it again in order to find what is
the difference between regular 64bit and 32bit on my system.

> If you observe the same error vs. loading tiff's, perhaps try checking
> further out in the loading, somewhere in the output from this:
>   $ gdk-pixbuf-query-loaders-32 | grep -A5 tiff
> and see if there's something there.

It all looked fine back then.

Maybe you could try to run the small programs I provided as
attachments to the GDK bug report? They should just work on your 64bit

Many thanks!

More information about the Linux-audio-user mailing list