[LAU] Problem getting started with Midi editing - no sound!

David Sumbler david at aeolia.co.uk
Mon Sep 14 19:42:24 UTC 2015

I have hesitated for weeks to post here with such a basic and possibly
stupid problem, but I am at my wits end with this.

I run Ubuntu 12.04 on a desktop computer and also on a small notebook.
Sound is fine on both of them, and I can play midi files through
tiMidity with no problem.

I want to use a midi-capable electric piano as an input device, and I
reckoned the first thing to do was to get some suitable software and
make sure I could play a midi file from a midi editor.

I have QjackCtl, Qtractor (I also have Muse) and Qsynth installed.  I
have spent weeks, on and off, trying to solve the basic problem of
getting some sound from Qtractor (or Muse), but although both the editor
and QjackCtl show that an imported midi file is actually being played, I
get no sound whatsoever.  This is true for both computers, even though
their hardware is pretty different.  As I said earlier, the sound on
both computers is fine in other contexts, so it is almost certainly some
fundamental error on my part, but I have no idea what is wrong.  I have
tried all sorts of different sets of connections in QjackCtl, but never
heard a note yet!

Having read various posts in the forum archive, I tried running
jack-metro.  QjackCtl shows that the metronome is running, but
connecting the metronome to the system outputs produces no sound, so the
problem seems to be at this level.

If anyone feels they have the patience to try to point me in the right
direction, I shall be very grateful indeed.


More information about the Linux-audio-user mailing list