[LAU] Linux automatic startup question

john gibby johnalan.gibby at gmail.com
Sat Apr 1 09:52:51 UTC 2017

Here, by the way, is the crossover_3chan contents:

  nano 2.6.2                                                File:

export LADSPA_PATH=/usr/local/lib/ladspa:/usr/lib/ladspa;
#          -a:woofer2 -pf:./woofer.ecp    -chorder:0,0,0,0,0,0,1,2 \
ecasound  -a:pre1                -z:mixmode,sum -z:nodb -B:rtlowlatency
-b:64 -f:f32_le,2,48000 -i:jack -pf:./pre1.ecp -o:loop,1 \
          -a:pre2,woofer -z:mixmode,sum -z:nodb -B:rtlowlatency -b:64
-f:f32_le,2,48000 -i:loop,1 \
          -a:pre2 -pf:./pre2.ecp -o loop,2 \
          -a:mid,tweeter         -z:mixmode,sum -z:nodb -B:rtlowlatency
-b:64 -f:f32_le,2,48000 -i:loop,2 \
          -a:woofer  -pf:./woofer.ecp    -chorder:1,2,0,0,0,0 \
          -a:mid     -pf:./mid.ecp       -chorder:0,0,1,2,0,0 \
          -a:tweeter -pf:./tweeter.ecp   -chorder:0,0,0,0,1,2 \
          -a:woofer,mid,tweeter -z:mixmode,sum -z:nodb -B:rtlowlatency
-b:64 -f:f32_le,6,48000 -o:jack

I've discovered that if I invoke this script using the /usr/local/bin path
by just typing crossover_3chan, it also does not work - apparently b/c it
is being run or owned by "root" instead of gibbyj.  I.e., if I run it from
/home/gibbyj/Downloads it works, but if I type "crossover_3chan" from some
other directory, and it finds the script in /usr/local/bin, it shows up in
ps -aux with "root", and it doesn't work.  But when I boot the computer,
it's not even sbowing up in ps -aux, with root OR gibbyj...
Thanks again...

On Sat, Apr 1, 2017 at 5:20 AM, john gibby <johnalan.gibby at gmail.com> wrote:

> Hi,
> I'm getting my Pianoteq app to run automatically when I start my
> computer.  So far, I'm using the startup script in QjackCtl to run the
> commands I need.  I have QjackCtl configured to startup automatically.
> It's starting up and running the commands OK; I see the programs come up
> when I boot the computer.  But one thing is not working:  a shell script
> named crossover_3chan, that invokes the ecasound application, which I'm
> using for a 3 channel speaker crossover network.  This crossover_3chan
> script works fine when I run it manually, but for some reason, running it
> within the QjactCtl startup script is not working.  When I execute ps -aux
> and look at the processes, it's not there, until I run it manually.  Here
> is the QjactCtl startup script I'm using:
> #!/bin/sh
> sleep 2
> /usr/bin/a2jmidid -e &
> sleep 2
> /usr/bin/aloop-daemon &
> sleep 2
> export LADSPA_PATH=/usr/local/lib/ladspa:/usr/lib/ladspa
> sleep 2
> hdspmixer &
> sleep 2
> "/home/gibbyj/Pianoteq/Pianoteq 5/i386/Pianoteq 5" &
> sleep 4
> crossover_3chan &
> I've tried various ways of invoking the crossover_3chan shell script.
> Currently, I have put the script into /usr/local/bin, which is why there's
> no path in front of the name, above.  But I also tried something like
> "/home/gibbyj/Downloads/crossover_3chan" & in the startup script, which
> didn't work either.
> Would it help if I make this shell script an "application", giving it a
> name, like Pianoteq and the other applications?  I've tried to figure out
> how to do that, in AVL/Debian, but am still not sure how.
> Thanks very much for someone's help!
> John
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20170401/2c3c03f7/attachment-0001.html>

More information about the Linux-audio-user mailing list