[LAU] Linux automatic startup question

john gibby johnalan.gibby at gmail.com
Sat Apr 1 18:35:44 UTC 2017

It's working!  I went back and removed the logging from the crossover_3chan
command (since it served its purpose), moved the order of the commands a
little, and now it works.  Thanks for the help!!

On Sat, Apr 1, 2017 at 1:02 PM, john gibby <johnalan.gibby at gmail.com> wrote:

> Some progress, but it's not working yet.  I added the log file as
> suggested, and it said something about TERM variable not being set.  I
> Googled that, and added a command like "export TERM xterm" to the QjactCtl
> startup script. That worked, and now:
> 1. the log file shows the normal output I should see when running
> crossover_3chan,
> 2. ps -aux shows the ecasound process running, under user name gibbyj,
> 3. I see what looks like a minimized Jack symbol on the far bottom right
> of my screen, which I don't think I saw before (I did check the box in
> QjactCtl to run it minimized.  Now I kinda wished I had not checked that
> box),
> 4. It is not quite working yet; I don't see the output I should see on
> hdspmixer, when I hit a note in Pianoteq, and
> 5. Strangely, I can't get QjackCtl to come out of minimized state anymore.
> Clicking on its icon does nothing.  The last command in the startup_utils
> script (/home...crossover_3chan) is now getting done; maybe it is causing
> Qjackctl to hang.  I see /usr/bin/qjackctl as process #3364 in ps -aux.
> On Sat, Apr 1, 2017 at 10:29 AM, Len Ovens <len at ovenwerks.net> wrote:
>> On Sat, 1 Apr 2017, john gibby wrote:
>> Hi,I'm getting my Pianoteq app to run automatically when I start my
>>> computer.  So
>>> far, I'm using the startup script in QjackCtl to run the commands I
>>> need.  I have
>>> QjackCtl configured to startup automatically.  It's starting up and
>>> running the
>>> commands OK; I see the programs come up when I boot the computer.  But
>>> one thing
>>> is not working:  a shell script named crossover_3chan, that invokes the
>>> ecasound
>>> application, which I'm using for a 3 channel speaker crossover network.
>>> This
>>> crossover_3chan script works fine when I run it manually, but for some
>>> reason,
>>> running it within the QjactCtl startup script is not working.  When I
>>> execute ps
>>> -aux and look at the processes, it's not there, until I run it
>>> manually.  Here is
>>> the QjactCtl startup script I'm using:
>>> #!/bin/sh
>>> sleep 2
>>> /usr/bin/a2jmidid -e &
>>> sleep 2
>>> /usr/bin/aloop-daemon &
>>> sleep 2
>>> export LADSPA_PATH=/usr/local/lib/ladspa:/usr/lib/ladspa
>>> sleep 2
>>> hdspmixer &
>>> sleep 2
>>> "/home/gibbyj/Pianoteq/Pianoteq 5/i386/Pianoteq 5" &
>>> sleep 4
>>> crossover_3chan &
>> you might try:
>>  . crossover_3chan
>> Assuming the script does not block.... and maybe even if it does.
>> I am assuming that these scripts of yours are chmod +x already.
>> --
>> Len Ovens
>> www.ovenwerks.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20170401/8d6ef595/attachment.html>

More information about the Linux-audio-user mailing list