[LAU] DOSemu Midi frustrations

Brent Busby brent at keycorner.org
Mon Apr 16 17:47:01 CEST 2018

Call me crazy, but the past several days, I've been trying to get Turtle
Beach SampleVision working on Linux.  Yes, I know, I'm crazy.  It's
because it has support for a lot of old hardware samplers that more
modern apps don't care about, and also there are lots of other DOS and
Windows 3.1 Midi apps from that era that would be interesting to use as
well if I could get this working.  When you use old hardware, you end up
using old software I suppose.

I actually have had very good luck with straight WIN32 apps and Midi
under Wine, since these days, Wine just picks up all your Alsa devices
and presents them to emulated Windows as though they were in the Control
Panel.  You can usually even choose which device you want in your
application's own GUI as though you had a Windows setup.

But SampleVision is a WIN16 app, which means it's just a stone's throw
away from DOS.  For Midi purposes, it practically is DOS.  Which means a
lot of the configuration for this is going to happen through DOS drivers
(real mode), CONFIG.SYS, AUTOEXEC.BAT, yadda yadda.  Wine seems to be
really bad at that, and seems to prefer pure Windows programs.  Hence
the adventures in DOSemu, which can actually run Windows 3.1 with SVGA
graphics in X.  I've even heard of people running Windows 95 under
DOSemu, which means while I'm crazy, apparently I'm not as crazy as
some people are.  :)

I've read Dave Phillips' articles and posts (lots of them...all of
them...all over the Internet...google google google...) about setting up
symlinks in ~/.dosemu/run/ to point device nodes in /dev/snd for virtual
midi devices.  I've been able to test from the Linux side that sending a
sysex dump through these virtual devices actually does produce data on
the hardware interface, provided the virtual devices have been connected
with aconnect beforehand.  In other words, the devices are doing what
they're supposed to do natively, and we've got no Midi problem in Linux.

Inside the DOS emulation though, nothing seems to be able to find an
interface, and I've tried lots of IRQ's.  I've run dosemu with strace,
and I do see it doing filehandle opens on my symlinks, which seem to
succeed, but at the DOS prompt, I'm still not able to find any Midi

Should I just give up on this?  I've seen lots of howto's that say it
should be possible to get Voyetra Sequencer Plus Gold for DOS working,
so in principle, I'm thinking this might work, if I can just get an Alsa
Midi device visible from DOS.  Is there any way from the DOS side to
scan for one to see if it's showing up anywhere?

- Brent Busby	+ ===============================================
		+ "The introduction of a new kind of music must
-- Studio    --	+  be shunned as imperiling the whole state, for
-- Amadeus/  --	+  styles of music are never disturbed without
-- Keycorner --	+  without affecting the most important political
-- Recording --	+  institutions."    --Plato, "Republic"
----------------+ ===============================================

More information about the Linux-audio-user mailing list