[LAU] death by ogg vorbis

Paul Davis paul at linuxaudiosystems.com
Tue Nov 6 20:29:51 CET 2018

strange problem ... looking for clues.

we have a slimdevices/logitech media server, and have had for more than a
decade. we have 2 or 3 playout devices, one class and two "receivers". the
system has worked solidly for a very long time.

about a month ago, i download some awesome new London jazz from a project
named Yuseef Kamal, as FLAC from Bandcamp. Sadly the project has since
broken up, but "Black Focus" is phenomenal.

As I usually do with FLAC or WAV downloads, I stash these files outside our
music repository, convert to a lossy compressed format and then move the
result into the music repository to keep the space down when we copy the
whole thing to an SD card or whatever.  The compressed format is generally
always Ogg/Vorbis.

So I did the same. Played the result on my main working computer (one
version of the repo), and on my laptop (another rsync'ed copy of the repo).
Entirely expectedly, it works normally.

But then, after a lot of head scratching, I realized that whenever I try to
play any of these files via the slimdevices/logitech server+devices, it
does something to the server and/or the devices that requires a complete
reset of the entire system. Switching to other music will not work - things
are dead, even though they are superficially alive. I have never seen this
behaviour from any other music/files.

I can play the same files via some other media app on the computer where
the server runs, and there are no problems.

I've repeated this "experiment" at least 4 times so far. Playing a single
track from the Yuseef Kamal album effectively crashes my
logitech/squeezebox system (though the server is still responsive and the
controller(s) still appear to do stuff. I've tried looking a debug logs
fromthe server, but have seen nothing to indicate what is happening. I even
reconverted from the original FLAC files, and tried those instead. No
difference in the behavior.

I have a few thoughts about things to try, but wanted to see if anyone else
had any suggestions on approaches to the problem, things to look for, etc.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/linux-audio-user/attachments/20181106/54a53bdb/attachment.html>

More information about the Linux-audio-user mailing list