[LAU] jconvolver does not find a running Jack2 server

david gnome at hawaii.rr.com
Wed Aug 7 08:24:26 CEST 2019

Hi Moshe!

On 8/6/19 7:51 PM, Moshe Werner wrote:
> Hi David,
> On Wed, Aug 7, 2019, 07:49 david <gnome at hawaii.rr.com 
> <mailto:gnome at hawaii.rr.com>> wrote:
>     On 8/6/19 5:44 PM, Moshe Werner wrote:
>      >   with jackd from commamd line:
>      >
>      > [moshew at moshe-laptop ~]$ jconvolver
>      > /usr/share/doc/jconvolver/DRC-Salon-Sofa/salonsofa.conf
>      > Cannot connect to server socket err = No such file or directory
>      > Cannot connect to server request channel
>      > jack server is not running or cannot be started
>      > JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1,
>      > skipping unlock
>      > JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1,
>      > skipping unlock
>      > Can't connect to JACK
>     Hmm, could jconvolver be needing the JACK server name?
>     Usage: jconvolver <options> <config file> {<connect file>}
>     Options:
>         -h                 Display this text
>         -v                 Print partition list to stdout [off]
>         -L <nframes>       Try to compensate <nframes> latency
>         -M                 Use the FFTW_MEASURE option [off]
>         -V                 Use vector mode processing [off]
>         -N <name>          Name to use as JACK client [jconvolver]
>         -s <server>        Jack server name
> As I stated in the OP
> "I also tried to run jconvolver -sjackd / jconvolver -sjackdbus but also 
> without success."
> Also tried
> jconvolver -sjackdmp
> jconvolver -sdefault
> I think if you don't use the option -s jconvolver should use to the 
> default server name.
> Thanks
> Moshe

I agree, it should use the default jack server name. Outside the list, 
Ralf mentioned that there's a bug in jconvolver that requires setting 
the server name regardless.

I use Cadence, too, but have no idea how to set the server name there.

qjackctl has an option to set server name. I've never set it and it 
shows "(default)". Could the parentheses be required as part of the name?

Could it also have to be "-s default" rather than "-sdefault"?

I noticed in the command line information you showed above, there was no 
-s setting. That's why I wondered if you'd tried it.

Just guessing, sorry if it doesn't help.

David W. Jones
gnome at hawaii.rr.com
authenticity, honesty, community

More information about the Linux-audio-user mailing list