[LAU] Behringer UMC1820 suddenly stopped working with JACK2 (after re-install)

nik at parkellipsen.de nik at parkellipsen.de
Mon May 6 22:24:33 CEST 2019


i recently re-installed Arch Linux on my laptop after a disk swap and suddenly JACK2 (non-dbus) doesn't run with my Behringer UMC1820
anymore. I kept the old system up-to-date and it was working perfectly well. Also, I don't remember making any special adjustments to
get it up and running.

My other cheapo Behringer (UCA202) still works fine, so i assume it's not a general USB audio problem ?

The device is still shown in alsamixer, levels can be set.

A friend tried it on her Mac and it worked there, so I assume the interface itself is still running.

uname -a says:

Linux atarashii 5.0.13-arch1-1-ARCH #1 SMP PREEMPT Sun May 5 18:05:41 UTC 2019 x86_64 GNU/Linux

I usually start jack2 like this (works with the other device):

jackd -P98 -dalsa -dhw:2 -p512 -n3 -o2 -r44100

The error message is:

ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian in 3bytes format
ALSA: cannot set channel count to 2 for playback
ALSA: cannot configure playback channel
Released audio card Audio2
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server

Has anybody experiences something similar ? I don't have any idea right now ... 


More information about the Linux-audio-user mailing list