[LAU] [LAD] zita-jacktools help needed

Frank Neumann beachnase at web.de
Sun Jun 14 00:02:11 CEST 2020

Hi Vince,

> Now I can import jacktools in Python without errors. But if I try to use
> it OR to run an example file (e.g. tobspect.py like in the ccc video), I
> get the following error:
> ImportError: libzita-jclient.so.0: cannot open shared object file: No
> such file or directory
> In the nabble thread, a user said that zita-jclient is installed to
> /usr/local/lib64, but zita-jacktools only included /usr/lib as the
> library path.
> So I copied libzita-convolver and libzita-jclient from /usr/local/lib64
> to /usr/lib, but I still get the same error message.

You likely forgot to update the shared loader's cache by running "ldconfig"
(as root). This is always necessary after installing new shared libraries.

Also, instead of copying the shared libraries from /usr/local/lib64 to /usr/lib64,
I suggest you add your /usr/local/lib64 path to the loader's search path
(perhaps by creating a new file in /etc/ld.so.conf.d/, this is slightly
dependant on your distribution).


More information about the Linux-audio-user mailing list