[LAU] Long-running jack_capture multi-track recording corruption?

Andrew Grathwohl andrew at grathwohl.me
Sat Apr 3 18:50:18 CEST 2021

I have not changed file systems, though I have tried the recordings now 
on three different file systems:

- ext4 (nvme drive)
- ext4 with dm-crypt full disk encryption (ssd)
- xfs (large SATA hard disk)

All three have yielded the same results.

Though the WAV file size limits idea is a solid one to explore. I am now 
running a test capture in FLAC and will report back with those 

On 2021-04-03 12:24, David Kastrup wrote:
> Andrew Grathwohl <andrew at grathwohl.me> writes:
>> Hi list,
>> I am using jack_capture to record 2 inputs and 20 outputs going
>> through SuperCollider for a duration of between 30-45 minutes, using
>> the following command line:
>> jack_capture -f wavex -p supernova:* test.wav
>> This has worked well for my use case for several years. However, since
>> yesterday this command line fails to capture the entire recorded
>> performance, despite jack_capture showing the meters responding to the
>> audio correctly. Whenever the recording duration exceeds approximately
>> 20 minutes, the output file will only contain the first 5-10
>> minutes. However, if we only do a 5-10 minute recording, the entire
>> recording is captured and saved properly.
> Sounds like a file size problem?  Something like a 2GiB or 4GiB related
> limitation?
> Have you changed file systems?

More information about the Linux-audio-user mailing list