[LAU] Long-running jack_capture multi-track recording corruption?

Kjetil Matheussen k.s.matheussen at gmail.com
Sun Apr 4 14:01:05 CEST 2021

Andrew Grathwohl:
> Hi list,
> I am using jack_capture to record 2 inputs and 20 outputs going through
> SuperCollider for a duration of between 30-45 minutes, using the
> following command line:
> jack_capture -f wavex -p supernova:* test.wav
> This has worked well for my use case for several years. However, since
> yesterday this command line fails to capture the entire recorded
> performance, despite jack_capture showing the meters responding to the
> audio correctly. Whenever the recording duration exceeds approximately
> 20 minutes, the output file will only contain the first 5-10 minutes.
> However, if we only do a 5-10 minute recording, the entire recording is
> captured and saved properly.
> Seeking any insights about how to diagnose/fix these problems. Anyone
> here know where I ought to start?

Hi, I'm the author of jack_capture.

Were you able to record more than 20 minutes of 22ch before with
jack_catpure before, and now it suddenly fails?

Have you upgraded or downgraded jack_capture and/or libsndfile since then?

Which version of jack_capture are you currently using?

Have you tried a different format than wavex?
(wav is probably the the safest format to try since it's one that has
been the most tested. Wav files has a 2gb limitation though, but
jack_capture automatically writes to a new file whenever it reaches
that limit.)

There was a problem many years ago that I used (by accident) a 32 bit
integer instead of 64 bit integer. Perhaps you are using one of those
quite old versions of jack_capture.

More information about the Linux-audio-user mailing list