[LAU] JACK doesn't play nicely with integrated Tiger Lake sound card (sound distorted)

nik at parkellipsen.de nik at parkellipsen.de
Wed Jan 5 10:34:14 CET 2022


as the title says, the integrated sound card of my notebook doesn't work nicely with JACK2. The sound 
is very distorted, it sounds like a sample format mismatch (i.e. the device expects S24_LE but F32 is sent).

My setup is plain JACK on top of Alsa, no pulseaudio or pipewire. I've tried several programs such as SuperCollider,
Firefox (with --enable-jack option) and my own, all the same phenomenon.

Another symptom is that clients don't detect the correct samplerate. If I start JACK with a samplerate
of 44100, SuperCollider still detects 48000.

Playing around with pulseaudio and pipewire, things work better.

I'm on Arch, don't use pulseaudio typically unless needed, but I've read that the problem occurs in other distros as well. 

Here's what lspci says:

00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20)

I have powersave enabled.

My typical start options are - jackd -P98 -dalsa -dhw:0 -r44000 -p512 -n5

I've tried an external USB card which works fine.

Anyone has a hint ? Can JACK force the samplerate/sample format somehow ?


More information about the Linux-audio-user mailing list