<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html;
      charset=windows-1252">
  </head>
  <body>
    <div class="moz-cite-prefix">On 11/3/20 11:31 PM, Tim E. Real wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:aa9f39f1-d59a-2acf-f546-43fdfccd5f6d@rogers.com">
      <meta http-equiv="Content-Type" content="text/html;
        charset=windows-1252">
      <p>Tested MusE with Jack 1.9.14:</p>
      <p>Successfully sent a 1536 byte sysex from one MusE instance to
        another.</p>
      <br>
      <p>Has Jack midi sysex length finally improved? Yay!<br>
      </p>
      <p>It sure didn't seem to be working years ago when I did the MusE
        sysex stuff.</p>
      <p><br>
      </p>
      <p>Thanks.</p>
      <p>Tim.</p>
      <p>MusE sequencer project.<br>
      </p>
      <p><br>
      </p>
    </blockquote>
    <br>
    <pre class="moz-quote-pre" wrap="">"Bonus question: is it possible to be warned when jack is dropping sysex
messages?"
</pre>
    <p>I forgot to mention, in MusE we call jack_midi_event_reserve(),</p>
    <p>´┐Żand if it fails, look for this message:</p>
    <p>"MidiJackDevice::queueEvent ME_SYSEX: buffer overflow, sysex too
      big, event lost"</p>
    <p>I did not see the message in the test above. IIRC years ago it
      would happen.<br>
    </p>
    <p>Tim.</p>
    <p><br>
    </p>
    <blockquote type="cite"
      cite="mid:aa9f39f1-d59a-2acf-f546-43fdfccd5f6d@rogers.com">
      <p> </p>
      <div class="moz-cite-prefix">On 11/2/20 6:25 PM, Alexandre DENIS
        wrote:<br>
      </div>
      <blockquote type="cite"
        cite="mid:20201103002555.0ca11422@cocalight">
        <pre class="moz-quote-pre" wrap="">Hi,

I try to understand why sysex go through jack MIDI sometimes, and
sometimes they are lost. I am aware that jack has a limit for the
maximum message size per period, but I am playing with program dump of
my Nordlead which are only 139 bytes -- definitely not huge.

I am running jackdbus with a2jmidid, through Catia. My system is Debian
+ kxstudio.

When I try an application with native jack MIDI, such as Reaper (with
jack backend) or MuSE, I can record sysex successfully, but when I play
it, it never reaches the hardware.

With applications using ALSA sequencer (tested with qtractor and
Rosegarden), I can record and play successfully sysex using ALSA.
However, I cannot record nor play sysex when connecting jack MIDI ports
instead (jack MIDI wrapper ports from a2jmidid).

Is this the expected behavior? Are we stuck with ALSA when we are
dealing with sysex messages?

Bonus question: is it possible to be warned when jack is dropping sysex
messages?

Thanks!
-a.

</pre>
        <br>
        <fieldset class="mimeAttachmentHeader"></fieldset>
        <pre class="moz-quote-pre" wrap="">_______________________________________________
Linux-audio-user mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Linux-audio-user@lists.linuxaudio.org" moz-do-not-send="true">Linux-audio-user@lists.linuxaudio.org</a>
<a class="moz-txt-link-freetext" href="https://lists.linuxaudio.org/listinfo/linux-audio-user" moz-do-not-send="true">https://lists.linuxaudio.org/listinfo/linux-audio-user</a>
</pre>
      </blockquote>
    </blockquote>
  </body>
</html>