Oh, and go here to find binaries and sources:
0.92_b3 is the same as 1.9.12, not 1.9.10.

Yes, this is one of the versions I tried. 

What I am trying to do is to use a tool jltcdump which is part of ltc-tools (brew install ltc-tools) - a tool for reading so called linear timecodes (smtpe) encoded in audio. 

Part of my problems is to begin with the two versions of jack - Jack1 and Jack2 - which seems to both exist and both be “stable”. The binary above - 0.92_b3 seems to be of the Jack2 kind if I am not mistaken. When I install that version it (JackPilot) starts fine but I don’t seem to be able to re-route the default audio device in System preferences to use JackRouter. JackRouter shows up in System preferences but there is nothing that indicates that any app that uses audio (such as iTunes) actually connects. I was hoping for functionality as in the Youtube tutorial from 2013 - https://www.youtube.com/watch?v=FhrJ9rTMcBU - where different audio clients show up in the routes of JackPilot but this is not repeatable for me as it was back in 2013 at least. 

Also, when I build and run ltc-tools with the above release I get some errors like these: 
$ ./jltcdump
unknown option character l
connect(2) call to jackdmp 1.9.11/jack-502/default/jack_0 failed (err=No such file or directory)

It seems like there is a call to “jackdmp” with some “unknown option character l”, so there seems to be some incompatibility with ltc-tools and this version of libjack (at least that is my guess). 

So then I instead try and install jack with “brew install jack” and I install a ltc-tools (brew install ltc-tools) which depend on this version of jack (which I guess is Jack1 ?). I then start jackd manually with jackd -d coreaudio and it starts. But with this setting there is nothing showing up at all in audio System Preferences. And I also get these errors "could not handle external client request” when a client accesses. The jltcdump program in this case seems to think that it has connected to the call to jackdmp seems to work with this version of jack. But it does not seem to receive any audio and jack d shows errors like "could not handle external client request” which makes me suspicious that there is some issue. So then I search for this error and find these GitHub discussions: https://github.com/Qix-/CaptainJack/issues/3 https://github.com/jackaudio/jack2/issues/305

…which, together with my own experiences and confusions, made me to believe that jack is broken on OSX. Then others here say that it is indeed working…which make me even more confused. But perhaps it is different use cases that we are talking about and jack on MacOS might still support some of them but perhaps not all. 

I also tried to use PortAudio (https://github.com/gordonklaus/portaudio) to do other types of audio processing, but this one also depends on jack and I got similar faults. So to me it seems like there are quite a few audio tools (don’t know how much they are used on MacOS though) that depend on jack and these tools have at least at some point been working on MacOS but that, at least to me, it seems like jack has fallen behind on MacOS which brings with it these other tool-chains. Not complaining at all. Just wanted to know if someone else was feeling the same pain - and it seems, as I said, that some things are working for some people.