[linux-audio-user] xruns - FC2/Planet(custom) vs. Gentoo(custom)

Mark Knecht markknecht at gmail.com
Sun Oct 3 20:59:07 EDT 2004

Lee & Fernando,
   Thanks for the pointers. I've emerged schedutils and will see what
it tells me.

   I'm actually makig some good headway on the Gentoo side. Being that
Gentoo is a system I use everyday it was of course set up to do far
more things than the Fedora partition which I set up to get a low
latency kernel. In looking at differences between the two I found a a
number of things:

1) Fedora Jack was 0.99, Gentoo was 0.98.1
2) Gentoo was running a whole host of processes at boot time - ntpd,
ntp-client, cupsd, and about 10 others of which I am not sure of their
reason for being there
3) I was running gkrellm, bbkeys and xscreensaver in my .xinitrc file

The I had previously tried turning off the 3 in #3 without much
effect. However, after updating to Jack 0.99.0 turning off the 3 in #3
has made a big difference. I have now been running 20 minutes at 64/2
with only 7 xruns total. Two come when alsaplayer starts playing the
CD. The other 5 have come while the CD is being played. These 5 are a
big improvement from the 50-100 I was getting earlier, but still not
good enough.

Also, the Fedora test has never cause an xrun when I press play in
alsaplayer, but under Gentoo it gives me two xruns every time.

Anyway, I think I'm making progress, but it's still not good enough.

Looking at X is another good thing to do. The Fedora build gives me
1700FPS running glxgears using 25% CPU while my Gentoo setup gives me
200FPS using 100% CPU. Clearly I'm accessing the graphics hardware
differently. This could certainly account for an odd time delay once
in awhile I'd think and may be part of why turning off gkrellm is

I'm wondering if the way that Fernando builds Jack is different than
the Gentoo ebuild? ?If so then I should try buildign by hand and, I
guess, placing that code someplace that is found before the
/usr/bin/jackd version. That may help if there is a difference. None
the less I think PlanetCCRMA users are in for a treat when this all
gets sorted out.

I'll let you more later in the week.


On Sun, 03 Oct 2004 20:28:19 -0400, Lee Revell <rlrevell at joe-job.com> wrote:
> On Sun, 2004-10-03 at 19:48, Fernando Pablo Lopez-Lezcano wrote:
> > On Sun, 2004-10-03 at 15:54, Mark Knecht wrote:
> > > <SNIP>
> > > > Yep.
> > > >
> > > > If you've allready checked the threading library versions (someone
> > > > allready metioned that) I would look at filesystems and mount options.
> > > >
> > > > X drivers are a possbilitlity, but most of the other drivers should be the
> > > > same as youre running the same kernel, so it reduces the number of
> > > > variables a lot.
> > > >
> > > > - Steve
> > > >
> > >
> > > SO I guess it could also be a problem of some sort with the Gentoo
> > > ebuilds for Jack or Jack apps. Another possibility I almost called
> > > attention to earlier is this little bit of text when Jack starts up:
> > > (It was in the initial email)
> > >
> > > <SNIP>
> > > 08:10:43.247 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p64 -n2
> > > 08:10:43.252 JACK was started with PID=14453 (0x3875).
> > > cannot write to jackstart sync pipe 4 (Bad file descriptor)
> > > jackd: wait for startup process exit failed
> > > jackd 0.98.1
> > > Copyright 2001-2003 Paul Davis and others.
> > > <SNIP>
> > >
> > > What is a 'jackstart sync pipe 4'? Could this error be part of the
> > > problem? I have to boot back to FC2 to see if it's there, but from
> > > memory I thought maybe it wasn't...
> >
> > Yes, that may be the problem, my guess would be that jack may not be
> > getting realtime priority. I would check that all processes involved
> > (jackd and the clients as well) are really running SCHED_FIFO (ie: with
> > realtime priority).
> >
> As a test, you could try building JACK from source (IOW, bypassing the
> Gentoo ebuild process) and see if the problem persists.  I agree with
> Fernando that this looks like a problem with the Gentoo ebuild.  I have
> never seen that 'jackstart sync' message before.  On 2.6 jackstart is
> completely unnecessary.  It looks like on Gentoo jackd might be a
> wrapper script that exec's jackstart or something, which fails because
> it can't get allcaps.  Just a guess, I don't have access to a Gentoo
> system.
> The problem is that until recently, it was a safe assumption that anyone
> using JACK would be on 2.4.  Audio on 2.6 is a pretty recent
> development, I would not be surprised if more bugs like this turn up.
> Lee

More information about the Linux-audio-user mailing list