[LAU] JACK and realtime in Ubuntu 7.10

Ernie Dulanowsky ernst at pulsewidth.ca
Wed Dec 5 00:44:45 EST 2007

I just had a similar experience.
I had installed the ubuntustudio-audio and audio-plugins metapackages
and linux-rt kernel on Fluxbuntu 7.10 RC. I got the same QJACKCtl
error. I had already made myself part of the audio group. I searched
the forums,found the tip about /etc/security/limits.conf and made
those changes, but still no success. Some further investigation showed
that QJACKCtlcould not access /dev/shm if I ran it as myself. If I ran
QJACKCtl using sudo, no problem.

Unfortunately that is where my investigation ended. I installed
Xubuntu and the ubuntustudio stuff and all is well.

I should probably post to the Fluxbuntu forum as well...


> > So my question is:  how can I run jack as a normal user in Ubuntu?
> The easy way is to install the ubuntustudio packages that are part of
> the normal ubuntu repository. apt-get install ubuntustudio-audio should
> do the trick.
> The thing to ensure is that your /etc/security/limits.conf contains
> these lines:
> @audio   -  rtprio     99
> @audio   -  memlock    512000
> @audio   -  nice      -19
> and that your user is part of the 'audio' group (it normally is by
> default).
> Normally the ubuntustudio packages take care of both these conditions.
> Note that should you have to add the lines or make your user member of
> the audio group, you have to logout and relogin in order for the changes
> to take effect.
> Greets,
> Pieter
> PS: While you're at it you can also install the realtime patched kernel
> for ubuntu (linux-rt).

"Both Rob and I see sound as shapes.
I only have to do this (makes a fist)
and he knows what sound I mean". - Autechre
Ernie Dulanowsky

More information about the Linux-audio-user mailing list