[LAU] AVSynthesis

Dave Phillips dlphillips at woh.rr.com
Tue Nov 30 15:25:17 UTC 2010

alex stone wrote:
> I've been experimenting with Casound, and have Blue installed ok as a
> front end. (Nice app)
> I've tried AVSynthesis, but can't get it to start, as it throws up the
> following errors:
> ------------------------------------------------------------------------------------------------------
> alex at parchmentstudios ~/Downloads/AVSynthesis_33_05_11 $ java -Xmx512m
> -Djava.library.path=./libo -cp AVSynthesiso.jar:./libo/*
> org.avs.AVSynthesis
> Exception in thread "main" java.lang.NoClassDefFoundError: org/avs/AVSynthesis
> Caused by: java.lang.ClassNotFoundException: org.avs.AVSynthesis
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
> Could not find the main class: org.avs.AVSynthesis. Program will exit.
> ------------------------------------------------------------------------------------------------------
> I've been through the dependencies, and everything seems to be ok.
> Any clues?
> Alex.

Hi Alex,

Getting AVS working is a non-trivial exercise. Unless there's greater 
interest here, perhaps you should contact me off-list. I'll first need 
to know what your system hardware is like (you must have accelerated 3D 
graphics capability).

Have you tried 'org.avs.AVSynthesiso' in your command string ? The 
command looks okay otherwise.

Cc'd to JP for further elucidation. :)



More information about the Linux-audio-user mailing list