[LAU] Hydrogen 0.9.4-1 doesn't launch anymore !!

Gabriel M. Beddingfield gabrbedd at gmail.com
Thu Jan 6 18:59:38 UTC 2011

Hi jy,

On Thu, 6 Jan 2011, jy wrote:

> strange thing actually,
> I just tried uninstalling/reinstalling hydrogen and liblash2
> and now even though apt-get says liblash2 is installed, i can't find it :
> $ sudo locate liblash

Don't use locate for stuff like this.  It's info that is 
cached daily into a database.

> $ ls -l /usr/lib/liblash*
> lrwxrwxrwx 1 root root   16 2011-01-06 19:20 /usr/lib/liblash.so.1 ->
> liblash.so.1.1.1
> -rw-r--r-- 1 root root 9420 2011-01-04 21:05 /usr/lib/liblash.so.1.1.1

This means that liblash2 is not installed or not installed 

> $ ldd hydrogen
> ldd: ./hydrogen: No such file or directory

Sorry... should be...

    $ ldd /usr/bin/hydrogen

      -- or --

    $ ldd $(which hydrogen)

...but that's no matter because it appears to be an 
installation issue with lash.

> looks like the documentation for liblash2 is there (even the deb in the
> cache), but it's not installed.
> I tried purging and reinstalling liblash2. it's still not here....

This will tell you if it's installed or not:

    $ dpkg-query --list liblash2

If it's installed, this will tell you what files it 

    $ dpkg-query --listfiles liblash2

If it says that it provides /usr/lib/liblash2.so.2.1.1 -- 
but the file is actually missing -- then you have an 
installation issue with liblash2.

Note that /usr/lib/liblash2.so.2 is always a symbolic link 
to the *real* so-file.


More information about the Linux-audio-user mailing list