[LAU] No duplex mode with the EHCI driver and USB hub. Is the problem solved?

Pablo Fernández pablo.fbus at gmail.com
Mon Nov 7 21:53:07 UTC 2011


A few days ago in the alsa users mailing list, Clemens pointed to a 
recent patch for the EHCI driver [1] [2] for solving the following problem:

The current TT scheduling doesn't allow to play and then record on a
full-speed device connected to a high speed hub.

In connection with this, there was a discussion here some months ago 
[3]. Some users said that they were not able to get jack working in 
duplex mode . I also tried to prepare my sister's notebook with a UA25EX 
and duplex did not work either. I encountered the same problem in the 
laptop of a friend of mine. In both cases, the computers have an Intel 5 
Series/3400 Series Chipset USB2 controller.  Jack always says "broken 

I have not tried the patch yet but it seems to work if you read the 
whole thread in alsa-users. Has someone else tried? Joan? Jeremy?

Regards, Pablo

[2] http://marc.info/?l=linux-usb&m=131973404328622

More information about the Linux-audio-user mailing list