[Jackaudio] Help requested: SuspendRefNum error/JackClient::Execute error

Sjoerd van Kreel sjoerdvankreel at gmail.com
Sun Jun 21 19:03:23 CEST 2020

Hi all!

I am the developer of XT-Audio (a project similar to PortAudio) which
provides a unified interface to a couple of audio I/O backends on windows
and linux, among them JACK. XT-Audio is implemented as a C interface to
these backends, and on top of that, bindings for C++, .NET and Java. Along
with the core library, I also provide a couple of sample programs (for each
language) and a GUI demo application which is implemented in .NET only. The
problem I currently run into is: when testing JACK using the GUI sample (a
WinForms application, run using Mono), I run into the SuspendRefNum and
JackClient::Execute errors immediately after starting an audio stream
(jack_activate) and after this point the application becomes unstable.
QJackCtl message window shows my app's ports being immediately disconnected
and I receive "server not running" errors. However this ONLY happens when
testing using my winforms demo app. I also provide a c++ console sample app
(runs JACK fullduplex by just copying input to output) and a .NET sample
console app which does the same thing. Both run without problems 100% of
the time. So at first I tried to find the error in my winforms app, but
i've been going through it for a couple of weeks now and can't seem to find
anything obviously wrong with it. Errors mentioned at
https://github.com/jackaudio/jack2/issues/307 look very similar to what i'm
encountering but i'm not sure they are actually related. Are there any
known problems that might cause the SuspendRefNum/JackClient::Execute error
sequence? I'm kind of at a loss here and any help would be greatly
appreciated. I'm running ubuntu 20.04 with jack 1.9.12. I also tried
various things like running the demo app before starting the JACK server,
the other way around, killing pulseaudio, using pasuspender etc, all to no
avail. My XT-Audio project is at https://github.com/sjoerdvankreel/xt-audio.
Binaries for the current version are at
https://sjoerdvankreel.github.io/xt-audio. Don't know if it's of any help,
but all of this used to run just fine under ubuntu 16.x (can't remember
jack version).

Best regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/jackaudio/attachments/20200621/0b15302f/attachment.html>

More information about the JackAudio mailing list