[Jackaudio] jack & Ableton - Windows

Giovanni gionogio at gmail.com
Mon Jun 22 21:56:17 CEST 2020

I solved my problem, so I am just answering for those who might have the
same problem in the future.
I probably had a different setting in my audio interface software,
different from the specified block size in my "target" string.
So probably SC was able to understand what block size to choose, while
Ableton was still trying to reach one of the two and failed.

I solved that just before my rehearsal, and eventually I got my degree :D
Thanks anyway!

Il giorno gio 18 giu 2020 alle ore 09:32 Giovanni <gionogio at gmail.com> ha

> Hi people,
> I am writing because I am experiencing a strange issue.
> I had a setup with Jack PortAudio (& Jack Control) for Windows, i opened
> them before (as admin), then opened Ableton and SuperCollider (also as
> admin) to bridge audio from one software to another. I also start Jack
> PortAudio with the following commands (going from Jack PortAudio ->
> Properties -> Shortcut -> Target):
>  "C:\Program Files (x86)\Jack\jackd.exe" -R -P95 -Xwinmme -S -d portaudio
> -d "ASIO::US-2x2 & US-4x4" -r44100 -p512
> I have been playing with this set-up from Jan to mid of March.
> Now I reopened my projects and something is wrong with that: when I play
> the test sine tone from Ableton, I can hear a sort of a Ring Mod, that is
> clearly a block size problem.
> I tried to switch block sizes - and sample rates - (both in JackControl
> and in the 'target' line of Jack PortAudio) but the only moment the test
> tone was playing kind of normally was once with 256 block size. But that
> time I had experienced a big problem: the sine tone was full of small
> clicks as my cpu was not handling it (which is really strange cause I
> normally have quite strong performances).
> So I really do not know what to do, also because this project was intended
> for my degree, which is tomorrow, but I have to rehearse this afternoon.
> Thanks for your attention
> Hope y'all are safe
> Respectfully
> Giovanni
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/jackaudio/attachments/20200622/940f50c7/attachment.html>

More information about the JackAudio mailing list