[Jackaudio] JACK/ALC1220 issues

Mike Uchima uchima at pobox.com
Wed Sep 23 16:41:22 CEST 2020

Hey, new subscriber here. I've been using JACK for several years but 
know just enough about it to get it to work (usually). I've hit a couple 
of issues with a new system build that have me stumped.

Specifics of the system: Ryzen 3700X; Asus Prime X470 Pro motherboard; 
using (or at least attempting to use) the on-board audio, which is an 
ALC1220. OS is Ubuntu 20.04 LTS; JACK is configured to run with realtime 

Issue #1: Can't get any output from the digital (S/PDIF) port. I've made 
sure S/PDIF is unmuted in alsamixer, and the S/PDIF output works fine 
with PulseAudio. I've tried outputting to all of the system ports that 
show in the JACK connection manager, and none of them produce any output 
on the S/PDIF port.

Issue #2: If I run with the default number of output channels (6), JACK 
stutters horribly with constant XRUNs. Already tried changing the 
--period option; if I increase it JACK fails to start, and if I decrease 
it the stuttering gets worse. Also tried changing --nperiods; increasing 
it prevents JACK from starting. If I disable the last 2 channels (i.e. 
run in 4 channel mode) the stuttering goes away.

I can live with #2 (don't really need the last 2 channels), but if I 
can't get #1 resolved I'll be looking at a 3rd party soundcard (internal 
or external) for this system.

Any thoughts/insights would be welcome.


More information about the JackAudio mailing list