[linux-audio-dev] [OT?] glibc problems

Ivica Bukvic ico at fuse.net
Fri May 2 16:45:00 UTC 2003

Hi all, I know this is off-topic, but at this point I could use any help
I could get since I am just about ready to do a clean reinstall
(Something that I do really not feel like doing right now).

I had Mdk 9.0 and upgraded it to 9.1. Since, when I have dynamically
linked apps to the /usr/lib/libc.so.6 (or /usr/lib/libc.so) I always get
the same error:

Error while loading shared libraries: /usr/lib/libc.so.6: invalid ELF

I tried reinstalling 9.1 glibc and glibc-devel and that did not fix it.
I also tried installing libelf rpm for mandrake and that did not do a
thing. Finally I even installed the newest cooker version of these two
files and I still come up with the same error. This brings me to a
conclusion that the problem lies somewhere else, but where?

Rebuilding of glibc from srpm eventually fails with some weird error
(can't remember it any more), so that option is out of question.
Furthermore, what is really odd, is that the clean install on another
machine of the same distro does not have this problem, yet the files in
question libc.so (and other related ones) are IDENTICAL to the ones I
have on this machine (at least they were before I installed the latest
glibc from the cooker).

I also checked binutils package and it is the same on both machines.

So what gives?

Does anyone have any suggestions as to how could I go about resolving
this issue?

Any help at this point is greatly appreciated! Sincerely,

Ivica Ico Bukvic, composer & multimedia sculptor

More information about the Linux-audio-dev mailing list