[linux-audio-dev] Tascam US428 Hangup

Karsten Wiese annabellesgarden at yahoo.de
Fri Nov 19 18:42:48 UTC 2004

Am Freitag 19 November 2004 17:53 schrieb Uwe Koloska:
> karsten wiese wrote:
> > 
> > erm no. for us122 etc (USB 1.1) OHCI is in charge as EHCI
> > is USB2.
> Ah -- I thought, that usb2 uses EHCI _and_ is downwards compatible 
> with usb-1.1.  So, while using EHCI I run USB 1.1.  (forgive me, I 
> know near to nothing about this stuff ;-)

Hardwarewise it is one chip yes, but on the kernel software side USB 1.1 traffic is handled by the OHCI stuff.
You don't have to bother about this. Mostly its also the same plug(s) for both OHCI & EHCI (or UHCI & EHCI) and the hardware knows, which part of the chip is to use.
> > us122 on OHCI really is a case for snd-usb-usx2y 0.8.6.
> > Have you already tried it?
> Will try it.  Is it part of Alsa 1.0.7?  The Release Note from 
> Jaroslav Kysela just mention
>    - usX2Y
>      - usx2y cleanups and fixes
>      - snd-usb-usx2y 0.7.3
this number is wrong. its really  0.8.6 in there.

>      - snd-usb-usx2y - crash fix for OHCI USB-HCDs
> Hope to get it installed on my SuSE 9.2 (the last time I tried to 
> build only the alsa-drivers, it hicks up with many errors I wasn't 
> able to resolv)

You can setup a standard suse kerneltree and only copy the usx2y subdir's content from alsa1.0.7/alsa-kernel/usb/usx2y to suse9.2kernel/sound/usb/usx2y.
I think....;-)

to be really shure, that you have an OHCI (and not UHCI) device you can look at/mail here the outputs of
	$ lsusb
	$ lspci

bis denn,

More information about the Linux-audio-dev mailing list