[LAD] Timers, hpet, hrtimer -> kind of solved (for too old motherboards)

hollunder at gmx.at hollunder at gmx.at
Tue Nov 10 13:40:51 UTC 2009

On Tue, 10 Nov 2009 12:48:42 +0100
Clemens Ladisch <clemens at ladisch.de> wrote:

> hollunder at gmx.at wrote:
> > $  dmesg | grep -i hpet
> > Kernel command line:
> > root=/dev/disk/by-uuid/3e47466f-5ca1-499b-85fc-152074f36364 ro
> > hpet=force pci 0000:00:11.0: Failed to force enable HPET
> > 
> > /dev/hpet was still created,
> Then you have it.  The message is probably because it doesn't need
> to be forced.

I added hpet=force because I found a line in dmesg that said
something along the lines of: hpet isn't available, try hpet=force

> See /proc/iomem at address fed00000.
cat /proc/iomem | grep -i fed00000 -> Nothing
> It's possible that your log buffer is too small and that the earlier
> HPET messages were lost.  Do you have more HPET-releated messages
> in /var/log/messages or /var/log/syslog?

cat /var/log/messages.log | grep -i hpet only found the kernel command
cat /var/log/syslog.log | grep -i hpet didn't find anything

> > but when I changed its group and told jack to use it I got:
> > This system has no accessible HPET device (Device or resource busy)
> "Busy" means that it's there, but already being used.  Many
> motherboard BIOSes do not initialize the third HPET interrupt, and
> the first two are taken by the kernel.
> Best regards,
> Clemens

Thanks a lot Clemens, but I'm still not sure what the issue is or how
to solve it.


More information about the Linux-audio-dev mailing list