[LAD] Half speed audio playback issue

Raymond Martin laseray at gmail.com
Mon Oct 5 18:23:12 UTC 2009

Hi all,

Just wondering if any of you can give me a few clues as to what the possible
culprits might be in the case of half speed (one octave down) audio playback.

I have recorded live audio into Audacity (stereo @48Khz) and exported it out
to a sound file (Ogg, MP3). It plays fine in Amarok, but at half speed in both
Ardour and Qtractor. Audacity is going straight to ALSA, Amarok through Xine
to ALSA.

Looks like some kind of problem with Jack, which is very possible, but I had
no problem with using fluidsynth through Rosegarden (I could not load an
audio file into it to test though?). I tried to play straight into guitarix,
rakarrak, etc. previously and ended up with really bad distorted sound, that
also sort of sounded like sampling/processing was not up to speed. I tried
with an rt kernel, but no difference (flaky audio hardware is possible).

Anyway, if you have experienced this before just let me know what you think
it is. Need to dig in further myself, but a few clues from more experiences
Linux "audionaughts" will probably help narrow it down faster.

Any input appreciated.


Raymond Martin

More information about the Linux-audio-dev mailing list