[LAD] building the new Guitarix LV2 Amp

hermann meyer brummer- at web.de
Tue Dec 11 18:29:38 UTC 2012

It isn't a problem to do that in a 32bit environment, but however, I 
will set the build flag for libgxw/gxwmm to cshlib (build shared libs) 
when the lv2 plug is set to build, to avoid such trouble.
As I said in the previous mail, just add --shared-lib to ./waf configure 
will solved it for now.


Am 11.12.2012 17:31, schrieb David Robillard:
> Looks like you are building against a static library. Since you are 
> building a shared module, pedantically you can't do this, in practice 
> you at least need to be sure all code is built with -fPIC. Presumably 
> the static library mentioned is not, which is your problem.
> I am not familiar with libgxmm or the guitarix LV2 work specifically, 
> sorry, no concrete suggestions.
> Gianfranco Ceccolini <franconassis at gmail.com> wrote:
> Hello all
> I've tried building the new LV2 Amp from guitarix and the following 
> error is ocurring
> /usr/bin/ld: default/libgxwmm/gxwmm/libgxwmm.a(controlparameter_83.o): 
> relocation R_X86_64_32 against `_ZTTN3Gxw16ControlParameterE' can not 
> be used when making a shared object; recompile with -fPIC
> default/libgxwmm/gxwmm/libgxwmm.a: could not read symbols: Bad value
> I've already installed the last LV2 from SVN.
> Using Debian Testing in my box.
> Any ideas on waht I'm doing wrong?
> Thanks for all
> Gian
> -- 
> Antes de imprimir pense em sua responsabilidade e compromisso com o 
> _______________________________________________
> Linux-audio-dev mailing list
> Linux-audio-dev at lists.linuxaudio.org
> http://lists.linuxaudio.org/listinfo/linux-audio-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-dev/attachments/20121211/9eb22dcd/attachment.html>

More information about the Linux-audio-dev mailing list