[LAD] Announcing PHASEX-0.14.96

Johannes Kroll jkroll at lavabit.com
Thu Jan 17 11:10:20 UTC 2013

On Thu, 10 Jan 2013 22:26:15 -0500
"William Weston" <whw at linuxmail.org> wrote:

> > ----- Original Message -----
> > From: Johannes Kroll
> > 
> > I played around with it, it's fun! GUI looks very cool, too.
> > 
> > After using it a few times, I noticed that some folders with strange
> > names had been created with files like patchbank, phasex.cfg,
> > phasex.map, sessionbank in them. The folder names contain weird
> > characters, Thunar file manager displays them as 'invalid encoding'.
> > One such folder showed up in my downloads folder, the other one in a
> > src directory I was working in, possibly the PWDs when I started
> > phasex... Has anybody else seen this behaviour?
> > 
> > I'm running Ubuntu 12.04 on x86-64. 
> These files and directories are created when a session is saved via
> LASH, JACK Session, or native session management.  I've seen this
> behavior once before, when first working on LASH support, and it
> turned out to be a character encoding problem with LASH supplied
> directory names.  The only thing I can think of here is to use the
> "C" locale instead of obtaining locale from the user's environment,
> so I've made this change in v0.14.97-dev.  Could you try the latest
> in git, and let me know how it goes?

I'm not using LASH, but I did save sessions in Phasex "natively". I
tried the latest git and I don't see the strange directories in the
working directory where I started Phasex. I don't know if they popped
up somewhere else, but I think they were in the WD, so I guess that
fixed it!

But I'm pretty sure that syncing Phasex to an external MIDI clock
worked before, now it doesn't. I'm sending MIDI Clock from Renoise to
Phasex. I checked that the ports are connected and the clock is sent
with qjackctl & aseqdump. Is it possible that some change between 0.96
and 0.97 created a problem with the MIDI Clock? 

More information about the Linux-audio-dev mailing list