[LAD] Announcing PHASEX-0.14.96

William Weston whw at linuxmail.org
Mon Jan 21 22:36:32 UTC 2013

> ----- Original Message -----
> From: Johannes Kroll
> On Thu, 17 Jan 2013 12:10:20 +0100
> Johannes Kroll <jkroll at lavabit.com> wrote:
> > But I'm pretty sure that syncing Phasex to an external MIDI clock
> > worked before, now it doesn't. I'm sending MIDI Clock from Renoise to
> > Phasex. I checked that the ports are connected and the clock is sent
> > with qjackctl & aseqdump. Is it possible that some change between 0.96
> > and 0.97 created a problem with the MIDI Clock? 
> By "problem" I mean that I remember the BPM value being updated by the
> MIDI Clock, now it isn't.
> I don't know if it's related, but the "Lock parameter (manual
> adjustment only)" checkbox in the "Map MIDI Controller" window of the
> BPM Pot is always checked after phasex startup. I tried turning it off,
> then saving a session. After reloading the session, the "Lock
> parameter" field has always the same value as before, it's apparently
> not affected by session loading. But it is affected by "Load MIDI map".
> Turning "Lock parameter" off however doesn't cause the BPM to be
> changed by the MIDI clock, so now I think I might have imagined it was
> doing that in 0.14.96... :-]

(I should have read this before responding to the first email...)

I just found a new issue with the BPM locking with v0.14.97, so I'm not
surprised at all if updating BPM from tempo sync got broken as well.
Getting this fixed will be a priority for v0.14.98.


More information about the Linux-audio-dev mailing list