[LAD] can't build libffado 2.2.1 under gentoo

Nikita Zlobin cook60020tmp at mail.ru
Wed Apr 13 18:27:17 UTC 2016

Hello, i'm trying to build libffado from proaudio overlay. The problem
seems to be in ffado itself.

Somewhat long time ago (about year) i could install it, but now i have
following problems on compilation:
- First, it seems, that it now uses more modern language features: the
  specified option --std=c99, added by one of ebuild's patch, as well
  as without any options (tried to build tarball with) gives long error
- With compiler flag --std=c++11 compilation continued for relatively
  long time, but then failed with following
  errors: http://pastebin.com/hkttBN9X

there seems to be one common feature: definition with "quadlet_t"
argument fails to overload same def with "byte_t" arg.

I looked to src/libutil/cmd_serialize.h, and there are four (with
original) variants for each functions... i don't understand, why only
quadlet_t - typed variant fails, while others proceed. What i found yet
is that this type is defined in raw1394 headers:

$ grep -r 'quadlet_t;' /usr/include
/usr/include/libraw1394/raw1394.h:typedef u_int32_t quadlet_t;

And what is interesting, when i tried to build from tarball manually:
$ scons -DCOMPILE_FLAGS='--std=c++11'
... that flag was not even passed to g++, so thanks for gentoo S).

$ gcc --version
gcc (Gentoo 4.9.3 p1.5, pie-0.6.4) 4.9.3

More information about the Linux-audio-dev mailing list