[LAD] can't build libffado 2.2.1 under gentoo

Adrian Knoth adi at drcomp.erfurt.thur.de
Wed Apr 13 19:33:09 UTC 2016

On 04/13/16 20:27, Nikita Zlobin wrote:

> Hello, i'm trying to build libffado from proaudio overlay. The problem
> seems to be in ffado itself.

Call me old-fashioned, but if it's an FFADO problem, the FFADO devel
list would have been the appropriate place to report.

If it's a gentoo problem, then well, some gentoo list.

Anyway, I've CC'ed ffado-devel. You probably need to subscribe:


> Somewhat long time ago (about year) i could install it, but now i have
> following problems on compilation:
> - First, it seems, that it now uses more modern language features: the
>   specified option --std=c99, added by one of ebuild's patch, as well
>   as without any options (tried to build tarball with) gives long error
>   list.

libffado is C++, so --std=c99 is never correct. Please file a bug report
against your ebuild.

I might be mistaken, but are you compiling a 32bit library on a 64bit
system? Is that intended to be a cross-compile? I have no idea if
anybody has ever tried this. Should work in theory, but no guarantees.

> - With compiler flag --std=c++11 compilation continued for relatively
>   long time, but then failed with following
>   errors: http://pastebin.com/hkttBN9X

On Debian, this compiles fine:


while this doesn't mean there's nothing wrong with FFADO, I find it more
likely to be a Gentoo problem, especially due to lack of reports from
other distros.

Any chance to try this in a clean environment, for instance a Fedora

And last not least: if you have a DICE device, you might not even need
FFADO anymore, provided you're running a recent kernel.


More information about the Linux-audio-dev mailing list