[LAD] [FFADO-devel] can't build libffado 2.2.1 under gentoo

Jonathan Woithe jwoithe at just42.net
Thu Apr 14 07:44:08 UTC 2016

On Thu, Apr 14, 2016 at 09:30:21AM +0200, Stefan Richter wrote:
> > On 04/13/16 20:27, Nikita Zlobin wrote:
> > > Hello, i'm trying to build libffado from proaudio overlay.
> [...]
> > > Somewhat long time ago (about year) i could install it, but now i have
> > > following problems on compilation:
> > > - First, it seems, that it now uses more modern language features: the
> > >   specified option --std=c99, added by one of ebuild's patch, as well
> > >   as without any options (tried to build tarball with) gives long error
> > >   list.
> > > - With compiler flag --std=c++11 compilation continued for relatively
> > >   long time, but then failed with following
> > >   errors: http://pastebin.com/hkttBN9X  
> Building from a recent ffado.org SVN checkout worked for me on Gentoo
> sometime earlier this year.
> But right now it fails to build for me too.
> $ gcc --version
> gcc (Gentoo 4.9.3 p1.2, pie-0.6.3) 4.9.3"
> [...]
> Build log:  http://pastebin.com/fRHScVVH
> Not sure what changed since the last successful build.  gcc was possibly
> the same.

In Nikita's report the errors are reported in src/libutil/cmd_serialize.h. 
This file hasn't been changed for ages and certainly not any time this year.
There may be something rather obscure going on, but it's hard to see that
any changes have been made to FFADO to cause Nikita's errors.  I wonder
there is something strange going on with the compiler or the compilation

In Stefan's report the error is different:

/usr/include/glibmm-2.4/glibmm/ustring.h:267:12: error: expected ‘;’ at
end of member declaration
   ~ustring() noexcept;

This file is included via libxml++'s exception.h header file.  I know there
have been some issues with libxml++ and newer gcc versions so I wonder
whether any of those are behind this.  I remember that libxml++ did throw me
some curveballs when I moved my development system from gcc 4.5.x to 4.8.x
but I can't remember the details - I'll look them up tonight.  It wasn't
anything that affected FFADO though.


More information about the Linux-audio-dev mailing list