[LAD] [FFADO-devel] can't build libffado 2.2.1 under gentoo

Jonathan Woithe jwoithe at just42.net
Thu Apr 14 13:44:09 UTC 2016

On Thu, Apr 14, 2016 at 03:25:37PM +0200, Stefan Richter wrote:
> On Apr 14 Jonathan Woithe wrote:
> > On Thu, Apr 14, 2016 at 09:30:21AM +0200, Stefan Richter wrote:
> > > gcc (Gentoo 4.9.3 p1.2, pie-0.6.3) 4.9.3"
> > > [...]
> > > Build log:  http://pastebin.com/fRHScVVH
> > > 
> > > Not sure what changed since the last successful build.  gcc was possibly
> > > the same.  
> > 
> > In Nikita's report the errors are reported in src/libutil/cmd_serialize.h. 
> > This file hasn't been changed for ages and certainly not any time this year.
> > There may be something rather obscure going on, but it's hard to see that
> > any changes have been made to FFADO to cause Nikita's errors.  I wonder
> > there is something strange going on with the compiler or the compilation
> > environment.
> > 
> > In Stefan's report the error is different:
> Unlike Nikita, I haven't added -std=c++11 yet.

Yes, so it seems - my bad.  Somehow I managed to convince myself that I'd
seen it in the pastebin log you posted, but I've just rechecked it and it
clearly isn't in there.  Evidently I need more sleep.

> > /usr/include/glibmm-2.4/glibmm/ustring.h:267:12: error: expected â?????;â?????? at
> > end of member declaration
> >    ~ustring() noexcept;
> >             ^
> > 
> > This file is included via libxml++'s exception.h header file.  I know there
> > have been some issues with libxml++ and newer gcc versions so I wonder
> > whether any of those are behind this.  I remember that libxml++ did throw me
> > some curveballs when I moved my development system from gcc 4.5.x to 4.8.x
> > but I can't remember the details - I'll look them up tonight.  It wasn't
> > anything that affected FFADO though.
> On the mainline Gentoo package repo (the only one which I use), there are
> now only the packages
> 	dev-cpp/libxmlpp-2.38.1
> 	dev-cpp/libxmlpp-2.40.1
> available.  I have 2.40.1 installed right now; downgrading to 2.38.1 is
> currently impossible since its build fails as described in
> https://bugs.gentoo.org/show_bug.cgi?id=567526.

A downgrade of libxmlpp is probably not needed since it seems you have the
same version that resulted in a successful build in the Debian build log
that Adrian linked to.

> Note that my build log also contains errors in
> /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/exception for
> example.

Yes, further down the log.  They are of the same form as the ustring.h
errors though, so whatever's tripping ustring.h up is probably responsible
for the g++-v4/exception woes as well.

> The Debian build log with successful build, which Adrian linked to, lists
> the following Debian package versions:
> 	gcc-5_5.2.1-26
> 	libxml++2.6-dev_2.40.1-1
> 	libglibmm-2.4-dev_2.46.2-1
> etc.
> I guess I attempt an upgrade to gcc-5 next.

It's strange, since I think you mentioned that the same thing happened for
you with a gcc 4.8.x on that system.  I guess 4.9.x could break something
which worked in 4.8.x but such behaviour would be more likely with gcc 5.
Still, stranger things have happened, and there's still the issue that the
Debian build worked fine.

> On Apr 14 Jano Svitok wrote:
> > can you add -std=c++11 to CXX_FLAGS or how is it called to enable C++11
> > extensions? Most of the errors come from these - noexcept, override,...
> I tried multiple things, among them
>   $ export CXXFLAGS=-std=c++11
>   $ export CUSTOM_ENV=True
>   $ scons -c
>   $ scons
> but so far I did not manage to inspire scons to add -std=c++11 to the gcc
> command line.

So where did it come from?  It must be something the ebuild is adding.


More information about the Linux-audio-dev mailing list