[linux-audio-user] Problem with jackd

Raphaël Haberer-Proust raph at gmx.fr
Wed Mar 12 05:43:00 EST 2003


first of all thanks for your mail

> For a start, you could rewrite the .asoundrc file to reflect the type
> of card you have. For example, this is what my .asoundrc file looks
> like, and I am using an envy24 chipset, which uses the snd-ice1712
> module. Now, that is what my .asoundrc looks like:

pcm.powermac {
   type hw
   card 0

ctl.powermac {
   type hw
   card 0

when I launch jackd, I have the same error messages:

titanium:~# jackd -d alsa -d powermac
jackd 0.50.0
Copyright 2001-2002 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

loading driver ..
creating alsa driver ... powermac|1024|2|48000|swmon|rt
ALSA lib pcm_hw.c:866:(snd_pcm_hw_open) open /dev/snd/pcmC0D0c failed:
No such file or directory ALSA: Cannot open PCM device alsa_pcm
cannot load driver module alsa
jack main caught signal 15

> Have you double-checked that the correct module for your soundcard is 
> loaded? Have you run alsamixer to see if the volume is turned up for
> the card's outputs? It might also be good to ensure that you have no
> OSS sound modules loading either.

alsamixer works fine, I also tried to rmmod all the modules that have
"oss" in their name, no change. These are the modules that are loaded:

titanium:~# lsmod
Module                  Size  Used by    Not tainted
snd-seq-oss            32592   0  (unused)
snd-seq-midi-event      3952   0  [snd-seq-oss]
snd-seq                52760   2  [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss            56948   0  (unused)
snd-mixer-oss          16608   1  [snd-pcm-oss]
snd-usb-audio          48528   0  (unused)
snd-rawmidi            18256   0  [snd-usb-audio]
snd-seq-device          5668   0  [snd-seq-oss snd-seq snd-rawmidi]
snd-powermac           42756   1 
snd-pcm                81808   0  [snd-pcm-oss snd-usb-audio
snd-powermac] snd-timer              15232   0  [snd-seq snd-pcm]
snd                    46220   0  [snd-seq-oss snd-seq-midi-event
snd-seq snd-pcm-oss snd-mixer-oss snd-usb-audio snd-rawmidi
snd-seq-device snd-powermac snd-pcm snd-timer] soundcore              
4584   5  [snd]

> Are you able to use the ALSA drivers with other software like xmms, or
> KDE to play MP3s and the like, both through OSS emulation and ALSA
> itself? xmms works fine with output "libOSS.so", with "libALSA.so" it
> plays the songs a bit too fast, I think I've read something about this
> in the mailing list. Do you think it has something to do with it?

> hth

Thanks a lot for helping me


clef publique :

S'il vous plaît, évitez de m'envoyer des attachements au format Word ou
PowerPoint. Voir
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20030312/a5788037/attachment.pgp 

More information about the Linux-audio-user mailing list