[linux-audio-user] planet CCRMA / muse core-dumps

Fernando Pablo Lopez-Lezcano nando at ccrma.Stanford.EDU
Fri Mar 21 21:33:00 EST 2003

> I got Red Hat 8.0 on my toshiba 4300 laptop (ymfpci sound card).
> I followed all the planet ccrma install advices and ended with 'apt-get 
> install muse'. But just after launch muse core-dumps. If I run 'muse
> some_song.mid' in a terminal I just can see the window with all the
> midi parts and then it disappears. It writes 'segmentation fault'.
> With my ymfpci card, I was able to play midifiles with playmidi (with 
> Mandrake 9.0) . Everythings seems fine except midi sequencers. I
> wasn't able to run no midi sequencers either with Mandrake 9, that's
> why I tried Red Hat.
> I believe muse works perfectly good on other machines with red hat and 
> planet ccrma. Everyone says that it works flawlessly, but mine
> doesn't:((
> Anyone has a clue to why muse can't run ? 

Hard to say why (obviously it works for me...). You could try running
muse from gdb and seeing where it segfaults. Or running "strace muse" to
see what system calls it was trying to do before dying. Maybe there is a
dependency that is not explicitly discovered by the build process and is
causing the segfault. 

I would also try to get rid of any configuration files you may have
around: remove (or move somewhere else) both ~/.musePrj and ~/.MusE

-- Fernando

More information about the Linux-audio-user mailing list