[linux-audio-user] Anyone using multiface+cardbus?

Jesse Chappell jesse at essej.net
Sun Mar 23 13:05:00 EST 2003

On Sun, 23 Mar 2003, R Parker wrote:

> What do you make of my IRQs, they're not consistent
> with what you're describing. Is this some newer bios
> aipc feature?
> The pci cards begin at 16 with two scsi controlers
> sharing interupt 16, at 18 we see a third scsi
> controler that isn't the same as the one on 16. It's
> just the same driver.

Ron, my dual mobo (asus a7m266-d) (amd-762 chipset)
 also uses this IRQ system.  As
discussed before I thought I had tamed latency problems, but
indeed I have not.   When I run this command while 'jackd -R' is
running (and a client is connected) I get massive overruns on
the order of 1-2 *seconds* every 5 seconds or so:

  dd if=/dev/zero of=/path/for/bigfile bs=1000 count=1000000
This will write a one gig file as fast as possible.  My IDE
drives are tuned properly with hdparm and I'm using SMP 
2.4.20 + LL + preemp + radeonDRM.  Also tried with 2.4.18 + LL.

$ cat /proc/interrupts
           CPU0       CPU1
  0:      59143      60400    IO-APIC-edge  timer
  1:       1948       2013    IO-APIC-edge  keyboard
  2:          0          0          XT-PIC  cascade
  8:          1          1    IO-APIC-edge  rtc
  9:          0          0    IO-APIC-edge  acpi
 12:      12170      12203    IO-APIC-edge  PS/2 Mouse
 14:      12232      12459    IO-APIC-edge  ide0
 15:         52        159    IO-APIC-edge  ide1
 18:          0          0   IO-APIC-level  Ensoniq AudioPCI
 19:       6613       6657   IO-APIC-level  eth0
NMI:          0          0
LOC:     119459     119465

(my AGP radeon7500 is on IRQ 16.. not shown above for some 
Although my BIOS allows me to specify IRQs for slots, the numbers 
there match the traditional style... not this >16 stuff.  I tried 
anyway, but no change in linux.

I just tried this test on another system, this one UP 2.4.20 + 
LL, similar results.  Anyone else care to try this informal 
disk-loading test?   If you have >= 1G of memory, use a 
count=2000000 (2GB file).


More information about the Linux-audio-user mailing list