[linux-audio-user] Re: RME hammerfall DSP Multiface: help needed

Robert Epprecht epprecht at solnet.ch
Mon Sep 8 10:01:01 EDT 2003

"Thomas Charbonnel" <thomas at undata.org> writes:

>>> 3) Run hdspmixer and see what signals you see when running audio
>>> through it. alsaplayer is fine for this purpose.
>> All the meters in the middle row show activity.
>> BTW: Alsaplayer says 'Failed to load output plugin "alsa". Trying
>> defaults"
>>      Is this a hint?

I have figured this one out:
I had installed the alsaplayer package from debian unstable and changed
this to alsaplayer-alsa now. The message from alsaplayer has disappeared.
Sorry for the noise.

> You are most certainly playing a mono signal through the OSS emulation
> layer. With hdspmixer preset 1, you should have signal coming out of all
> the physical outputs, and also a VERY LOUD signal on the line outs, as all
> the playback channels are routed to the line outs and thus summed up.

It was a *stereo* signal, as the meters show clearly different levels for
left and right channels. But no signal on any meters in the last row.

> How is the card wired up ?
I don't know ;-)

I just run hdsploader a few times (until it gives no errors, which means
at least two times, sometimes three), start hdspmixer from alsa-tools 0.9.6
and then alsaplayer. I did *not* run amixer.  Do I get that right, that
hdspmixer replaces it and there is no need for amixer when I run hdspmixer?

With the *old* alsaplayer installation I got signals on all the meters of
the second row, all left channels showing same level, different from the
right channels.  All this channels where muted when starting up, but
un-muting them did *not* result in any signal showing up in the last row.

With the new alsaplayer-alsa installation and alsaplayer -o alsa -d plughw:0
I do not get the warning from the player any more. The first two channels
in the middle row show a stereo signal. Below that I see 'All 1+2' and
have tried to set this to different output channels...
Still no signal in the third row (faders are up), and still no sound...

> Do the meters show signal going through the outputs (3rd hdspmixer row) ?
No, I have tried many different things, including setting all channels to
mid-range and trying to set signal routing with amixer before starting
hdspmixer, but I have *never* seen a signal in the last row using Linux.
The card *does* work on 'another' OS, but this is not an option for me ;-)

BTW: Does firmware version still matter when I do use hdsploader?
     I baught the card very recently. How can I find out what firmware
     is on the card?

I think I could have made a very basic newbie mistake, even though I *did*
a lot of searching on the net, and did a lot of RTFM. I do not pretend
that I understood all of it, though.

Maybe this is wrong:
I do have installed jackd from Debian unstable, but I think did *not* start
it AFAIK.  'ps -A | grep jack' shows nothing. I wanted to proceed step
by step, but maybe this was the mistake?  How would I start jackd correctly
for my setup?  I had no luck so far with my attempts to do so, and wanted
to defer that.

Or another possibility:
I had tried both ways, installing ALSA from debian packages and installing
it from source. Maybe I did a mistake when trying to uninstall the self
compiled version (which did not work either) before I re-installed the
Debian packages?

I am currently reading the manual of RME and thinking about installing
the cvs ALSA version. Or maybe I should wipe out my disk and start again
with a new system... (oh, I would not like that too much ;-)

Thanks a lot for all the help I have got so far!
Robert Epprecht

More information about the Linux-audio-user mailing list