[linux-audio-user] HDSP and "play"

Aaron Trumm aaron at nquit.com
Fri Sep 26 13:59:00 EDT 2003

This sounds a bit like what Mark Knecht was describing that was happening
with his HDSP

he downgraded the HDSP firmware from rev 68 to rev 65...

----- Original Message -----
From: <BrbrOfSvl at aol.com>
To: <linux-audio-user at music.columbia.edu>
Sent: Friday, September 26, 2003 12:25 PM
Subject: [linux-audio-user] HDSP and "play"

> Hi,
> Matt again.  So if you remember I have this problem where my hdsp freezes
any time I use play (or any app that utilizes the play program, like maybe
(?) audacity...).  When I use play, it plays the soundfile, but afterward, I
can't open any programs that would use my soundcard (some open but say it
can't find the device or that the device is in use).  When I run "ps aux"
there's no indication of play being there.  However, when I run play and it
gets to the end of the soundfile, I hear what sounds like an amp clip, and I
get this:
> /usr/bin/play: line 205:  1686 Segmentation fault      sox $volume $fopts
$fopts2 "$filename" $arch_defines $device $effects
> The 1686 before the Segmentation fault seems to change depending on the
soundfile (1802 is another I've had)... I'm not really sure what that number
is.  So I opened up my /usr/bin/play in vi to see what was in line 205 (I've
displayed the last bit of the program):
> # If name is "rec" then record else assume user is wanting to play
> # a sound file.
> if [ "$program_name" = "rec" ]; then
>     # Don't send data to stdout if they are reading from it.
>     if [ "$filename" = "-" ]; then
>       echo "Send break (control-c) to end recording" 1>&2
>     else
>       echo "Send break (control-c) to end recording"
>     fi
>     sox $volume $arch_defines $fopts $device $fopts2 "$filename" $effects
> else
>     sox $volume $fopts $fopts2 "$filename" $arch_defines $device $effects
> fi
> Line 205 is the final fi, but the line above that is the one that appears
in the "error" message I get running play.  Is there something in that line
(or the rest of the program) that I should change to get it to work with my
hdsp?  I have an onboard nVidia soundcard that works with play just fine,
and aplay works fine with both cards.  Is it a problem in the play program,
or maybe the alsa hdsp driver I'm using?  Another thing I noticed is that
when I use play, the signal is being sent to all the channels on the
hdspmixer, whereas when I use aplay, it sends it just to the first two.
What gives?
> Also, when this happens, I've been rebooting the machine... is there a way
maybe to restart alsa instead?
> Thanks,
> Matt

More information about the Linux-audio-user mailing list