[linux-audio-user] midi troubles

C. Villard chvillard at wanadoo.fr
Sat Jan 3 11:24:10 EST 2004


Before starting, I want to say that I have already spent a lot of time 
trying to make Brahms, Rosegarden, Solfege or Jazz+ working, and spent a 
lot of my internet time too (ohh just some few hours left on my provider 
account !). So, I'm looking for a good answer, but perhaps it's not 
possible ? I've read a post on a french list of a guy who's saying that 
he uses linux since the beginning and that, after bigs probs sometimes, 
everything go fine except...midi that never seems to work !!! It seems 
that I'm taking this way and it's not funny

Well... my computer is a PIV with a P4S8X-X Asus motherboard ; this 
motherboard includes a AD1980 chip for sound, and there's also a 
midi/game port on th motherboard ; I've bought a cable to get this port 
outside the box and have plug on it (with a midi cable) my Alesis qs8 
For linux, it's an mdk 9.2 download edition. Alsa is running (message at 
boot) and the driver choosen for the sound chip by the sytem is the 
intel8x0 one.

Last thing, I can hear sound without difficulty : when X runs afeter 
boot, I hear the little jingle witch comes with.


Problems :

- first, it seems that midi is not existing for linux. For example, when 
I launch K mid, in the part "configuration" midi , it's noticed "alsa 
device" but, when playing a mid file, no sound goes out from my qs8.
When I try to launch Artscontrol, in midi part, there's nothing for 
input or output.

-I've succeded to install rosegarden 4 with rpm packages ; it has been 
very difficult because when I was trying to install rose. It tells me 
"no librosegarden" and when trying installing "libr." answer was "no 
....roseg." !!!!! So someone tells me "urpmi rosg. libros." : it worked 
!!! But rosegarden don't work ; when trying to import a midi file, it 
doesn't work (no sound) and begin to become very instable (window 
freezing, no response ...) ; when I try to record I get the mess "no 
audio subsystem installed"  well......
- Jazz...never installed ; when I try to, a lib is always missing, same 
for Solfege, even if the lib is already installed (it's the case for a 
gtkhtml one for example)
-Brahms says that there's no artsmidi.h even if I find it in 

So I'm very disappointed by these things and I've tried everything I 
could without succes.

I'm looking for a simple way to install and correctly run these progs ; 
if somebody........


More information about the Linux-audio-user mailing list